yarn : 无法加载文件 node\yarn.ps1;npm : 无法加载文件node\npm.ps1,因为在此系统中禁止执行脚本,解决方法

技术知识 2021-02-07 13:39:56 阅读 317 次
> vs code中报错: yarn : 无法加载文件 node\yarn.ps1;npm : 无法加载文件node\npm.ps1,因为在此系统中禁止执行脚本,解决方法如下: - 首先以管理员的身份运行 VS Code . - 在终端执行 get-ExecutionPolicy,打印显示出 Restricted,表示禁止状态. - 接下来在终端执行 set-ExecutionPolicy RemoteSigned. - 在此输入 get-ExecutionPolicy查看,显示 RemoteSigned. > 之后再使用yarn 或npm install 时,就不会再出现如上所述的问题了。
您可能感兴趣的
国内使用 npm 速度很慢,你可以设置npm淘宝镜像或使用淘宝定制的 cnpm (gzip 压缩支持) 命令行工具
国内使用 yarn 速度很慢,默认是去 npm/yarn 官方镜像源获取需要安装的具体软件信息,你可以重新修改镜像源。与npm命令比较
npm 默认会使用 C:\Users\Administrator\AppData\Roaming\npm-cache 目录,不仅不便于管理而且占用C盘空间
如果使用 yarn 速度很慢,你可以设置淘宝镜像
Top